您现在的位置是:首页 > 心得笔记 > 编程设计编程设计

【易语言】密码判断大小写以及数字

言成2019-07-15【编程设计】人已围观

简介:.版本 2.子程序 验证_是否合理, 逻辑型, , 判断密码是否包括大写小写字母数字 真=合理 假=不合理.参数 参_文本, 文本型.局部变量 局_长度, 整数型.局部变量 局_循环次数,

.版本 2

.子程序 验证_是否合理, 逻辑型, , 判断密码是否包括大写小写字母数字 真=合理 假=不合理
.参数 参_文本, 文本型
.局部变量 局_长度, 整数型
.局部变量 局_循环次数, 整数型
.局部变量 局_字符代码, 整数型
.局部变量 局_包括大写字母, 逻辑型
.局部变量 局_包括小写字母, 逻辑型
.局部变量 局_包括数字, 逻辑型

' 65-90 大写字母  97-122 小写字母  48-57 数字
局_长度 = 取文本长度 (参_文本)

.计次循环首 (局_长度, 局_循环次数)
    局_字符代码 = 取代码 (参_文本, 局_循环次数)
    ' 判断是否为大写字母
    .如果真 (局_字符代码 ≥ 65 且 局_字符代码 ≤ 90)
        局_包括大写字母 = 真
        ' 调试输出 (局_循环次数, “大写字母”)
    .如果真结束
    .如果真 (局_字符代码 ≥ 97 且 局_字符代码 ≤ 122)
        局_包括小写字母 = 真
        ' 调试输出 (局_循环次数, “小写字母”)
    .如果真结束
    .如果真 (局_字符代码 ≥ 48 且 局_字符代码 ≤ 57)
        局_包括数字 = 真
        ' 调试输出 (局_循环次数, “数字”)
    .如果真结束

.计次循环尾 ()

返回 (局_包括大写字母 = 真 且 局_包括小写字母 = 真 且 局_包括数字 = 真)

Tags:易语言

很赞哦! ()

文章评论

本站推荐

站点信息

  • 建站时间:2019-5-1
  • 文章统计30篇文章
  • 标签管理标签云
  • 个人微信号:扫描二维码,关注我