您现在的位置是:首页 > 心得笔记 > 编程设计编程设计

【易语言】九九乘法口诀表 用计次循环首和判断循环首两种方式编写

言成2019-05-26【编程设计】人已围观

简介:九九乘法口诀表 用计次循环首和判断循环首两种方式编写

1.用计次循环首 编写
 
.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 i, 整数型
.局部变量 a, 整数型

.计次循环首 (9, i)

    .计次循环首 (i, a)
        编辑框1.加入文本 (到文本 (a) + “x” + 到文本 (i) + “=” + 到文本 (a × i))
        编辑框1.加入文本 (“  ”)
    .计次循环尾 ()
    编辑框1.加入文本 (#换行符)
.计次循环尾 ()

2.用判断循环首 编写
 
.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 i, 整数型
.局部变量 a, 整数型

i = 1

.判断循环首 (i ≤ 9)
    a = 1
    .判断循环首 (a ≤ i)
        编辑框1.加入文本 (到文本 (i) + “x” + 到文本 (a) + “=” + 到文本 (a × i))
        编辑框1.加入文本 (“  ”)
        a = a + 1
    .判断循环尾 ()
    编辑框1.加入文本 (#换行符)
    i = i + 1
.判断循环尾 ()

Tags:

很赞哦! ()

文章评论

本站推荐

站点信息

  • 建站时间:2019-5-1
  • 文章统计22篇文章
  • 标签管理标签云
  • 个人微信号:扫描二维码,关注我